Click or drag to resize

RenderContentGenerateQuickContentPreview Method

Generate a quick render content preview

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static Bitmap GenerateQuickContentPreview(
	RenderContent c,
	int width,
	int height,
	PreviewSceneServer psc,
	bool bSuppressLocalMapping,
	int reason,
	ref Result result
)

Parameters

c
Type: Rhino.RenderRenderContent
Render Content
width
Type: SystemInt32
Image width
height
Type: SystemInt32
Image height
psc
Type: Rhino.RenderPreviewSceneServer
PreviewSceneServer
bSuppressLocalMapping
Type: SystemBoolean
SuppressLocalMapping
reason
Type: SystemInt32
ContentChanged = 0, ViewChanged = 1, RefreshDisplay = 2, Other = 99
result
Type: Rhino.CommandsResult
Rhino.Command.Result value for successfull quick image creation

Return Value

Type: Bitmap
The Bitmap of the quick render content preview
See Also