Click or drag to resize

StringParserParseNumber Method

Parse a string expression to get a number

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static int ParseNumber(
	string expression,
	int max_count,
	StringParserSettings settings_in,
	ref StringParserSettings settings_out,
	out double answer
)

Parameters

expression
Type: SystemString
String to parse
max_count
Type: SystemInt32
Maximum number of characters to parse
settings_in
Type: Rhino.InputStringParserSettings
Determines what input will be parsed
settings_out
Type: Rhino.InputStringParserSettings
Reports the results of the parse operation
answer
Type: SystemDouble
The number result of the parse operation

Return Value

Type: Int32
Count of characters in expression parsed if ParseNumber() returns 0, parse was unsuccessful
See Also