Click or drag to resize

SurfaceFilletBaseNonRationalCubicArcs Method

make fillet surfaces and hack them up to active pieces. Adjusts cross sections

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public bool NonRationalCubicArcs(
	int railDegree,
	bool bExtend,
	List<Brep> Fillets
)

Parameters

railDegree
Type: SystemInt32
The degree of the rail
bExtend
Type: SystemBoolean
If true, when one input surface is longer than the other, the fillet surface is extended to the input surface edges.
Fillets
Type: System.Collections.GenericListBrep
the fillet8s that were created

Return Value

Type: Boolean
true if successful
See Also