Click or drag to resize

SurfaceFilletBase Methods

The SurfaceFilletBase type exposes the following members.

Methods
  NameDescription
Protected methodChangeFilletRadius
This will clear out the existing rails and fillet surfaces, and redo the offset intersections, etc.
Public methodStatic memberCreateG2ChordalQuinticFilletSrf
Creates a surface fillet using G2 chordal Quintic arc approximations as sections
Public methodStatic memberCreateNonRationalCubicArcsFilletSrf
Creates a surface fillet using Non-rational Cubic arc approximations as sections
Public methodStatic memberCreateNonRationalCubicFilletSrf
Creates a fillet using non-rational Cubic sections with a tangent slider
Public methodStatic memberCreateNonRationalQuarticArcsFilletSrf
Creates a surface fillet using Non-rational Quartic arc approximations as sections
Public methodStatic memberCreateNonRationalQuarticFilletSrf
Creates a fillet using non-rational Quartic sections with a tangent and inner slider
Public methodStatic memberCreateNonRationalQuinticArcsFilletSrf
Creates a surface fillet using Non-rational Quintic arc approximations as sections
Public methodStatic memberCreateNonRationalQuinticFilletSrf
Creates a fillet using non-rational Quintic sections with a tangent and inner slider
Public methodStatic memberCreateRationalArcsFilletSrf
Creates a standard surface fillet using rational arc sections
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Public methodG2ChordalQuintic
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodIsInitialized
Check to see if the fillet is properly initialized. If it is not, then the selected curves, surfaces, and/or radius must be adjusted in some way before creating the fillet
Public methodNonRationalCubic
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodNonRationalCubicArcs
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodNonRationalQuartic
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodNonRationalQuarticArcs
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodNonRationalQuintic
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodNonRationalQuinticArcs
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodRationalArcs
make fillet surfaces and hack them up to active pieces. Adjusts cross sections
Public methodTrimBreps
If the two input breps are the same, TrimmedBreps[1] will be empty. The constructor idoes everything necessary for this to be called. Calles to the various fillet creation members will not change the result.
Top
See Also