Click or drag to resize

GeometryBaseGeometryReferenceEquals Method

Determines if two objects are respectively shallow copies, new managed instantiations of the same geometry, or similar internal references to the exact same geometry, both in managed and in unmanaged code.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.2
Syntax
public static bool GeometryReferenceEquals(
	GeometryBase one,
	GeometryBase other
)

Parameters

one
Type: Rhino.GeometryGeometryBase
The first object
other
Type: Rhino.GeometryGeometryBase
The other object

Return Value

Type: Boolean
True if indeed the objects are really the same. False otherwise.
See Also