Click or drag to resize

ExtrusionCreateBoxExtrusion Method

Gets an extrusion from a box.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Extrusion CreateBoxExtrusion(
	Box box,
	bool cap = true
)

Parameters

box
Type: Rhino.GeometryBox
IsValid must be true.
cap (Optional)
Type: SystemBoolean
If true, the base and the top of the box will be capped. Defaults to true.

Return Value

Type: Extrusion
Extrusion on success. null on failure.
See Also