Click or drag to resize

ExtrusionGetProfilePlane Method

Gets the 3D plane containing the profile curve at a normalized path parameter.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Plane GetProfilePlane(
	double s
)

Parameters

s
Type: SystemDouble
0.0 = starting profile 1.0 = ending profile.

Return Value

Type: Plane
A plane. The plane is Invalid on failure.
Remarks
When no mitering is happening, GetPathPlane() and GetProfilePlane() return the same plane.
See Also