Click or drag to resize

SubDVertexListAdd Method

Add a new vertex to the end of the Vertex list.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public SubDVertex Add(
	SubDVertexTag tag,
	Point3d vertex
)

Parameters

tag
Type: Rhino.GeometrySubDVertexTag
The type of vertex tag, such as smooth or corner.
vertex
Type: Rhino.GeometryPoint3d
Location of new vertex.

Return Value

Type: SubDVertex
The newly added vertex.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionIf tag is unset or non-defined.
See Also