Click or drag to resize

MeshFaceListSetFace Method (Int32, Int32, Int32, Int32, Int32)

Sets a quadrangular face at a specific index of the mesh.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool SetFace(
	int index,
	int vertex1,
	int vertex2,
	int vertex3,
	int vertex4
)

Parameters

index
Type: SystemInt32
A position in the list.
vertex1
Type: SystemInt32
The first vertex index.
vertex2
Type: SystemInt32
The second vertex index.
vertex3
Type: SystemInt32
The third vertex index.
vertex4
Type: SystemInt32
The fourth vertex index.

Return Value

Type: Boolean
true if the operation succeeded, otherwise false.
See Also