Arc Constructor (Point3d, Double, Double) |
Initializes a new horizontal arc at the given center point, with a custom radius and angle.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Arc(
Point3d center,
double radius,
double angleRadians
)
Public Sub New (
center As Point3d,
radius As Double,
angleRadians As Double
)
Parameters
- center
- Type: Rhino.GeometryPoint3d
Center point of arc. - radius
- Type: SystemDouble
Radius of arc. - angleRadians
- Type: SystemDouble
Sweep angle of arc (in radians)
See Also