Click or drag to resize

Arc Constructor (Point3d, Point3d, Point3d)

Initializes a new arc through three points. If the points are coincident or co-linear, this will result in an Invalid arc.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Arc(
	Point3d startPoint,
	Point3d pointOnInterior,
	Point3d endPoint
)

Parameters

startPoint
Type: Rhino.GeometryPoint3d
Start point of arc.
pointOnInterior
Type: Rhino.GeometryPoint3d
Point on arc interior.
endPoint
Type: Rhino.GeometryPoint3d
End point of arc.
See Also