Click or drag to resize

Arc Constructor (Point3d, Vector3d, Point3d)

Initializes a new arc from end points and a tangent vector. If the tangent is parallel with the endpoints this will result in an Invalid arc.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Arc(
	Point3d pointA,
	Vector3d tangentA,
	Point3d pointB
)

Parameters

pointA
Type: Rhino.GeometryPoint3d
Start point of arc.
tangentA
Type: Rhino.GeometryVector3d
Tangent at start of arc.
pointB
Type: Rhino.GeometryPoint3d
End point of arc.
See Also