Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ON_SubDComponentParameter Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDComponentParameter ()=default
 
 ON_SubDComponentParameter (const class ON_SubDEdge *e, double p, const class ON_SubDFace *active_face)
 
 ON_SubDComponentParameter (const class ON_SubDFace *quad_face, double quad_s, double quad_t)
 
 ON_SubDComponentParameter (const class ON_SubDFacePtr quad_fptr, double quad_s, double quad_t)
 
 ON_SubDComponentParameter (const class ON_SubDVertex *v, const class ON_SubDEdge *active_edge, const class ON_SubDFace *active_face)
 
 ON_SubDComponentParameter (const ON_SubDComponentParameter &)=default
 
 ON_SubDComponentParameter (const ON_SubDEdgePtr eptr, double p, const class ON_SubDFace *active_face)
 
 ON_SubDComponentParameter (const ON_SubDFace *face, ON_SubDFaceParameter fp)
 
 ON_SubDComponentParameter (const ON_SubDFacePtr fptr, ON_SubDFaceParameter fp)
 
 ON_SubDComponentParameter (const ON_SubDVertexPtr vptr, const class ON_SubDEdge *active_edge, const class ON_SubDFace *active_face)
 
 ON_SubDComponentParameter (ON_SubDComponentId cid)
 
 ON_SubDComponentParameter (ON_SubDComponentId edge_id, double p, ON_SubDComponentId active_face_id)
 
 ON_SubDComponentParameter (ON_SubDComponentId face_id, ON_SubDFaceParameter fp)
 
 ON_SubDComponentParameter (ON_SubDComponentId vertex_id, ON_SubDComponentId active_edge_id, ON_SubDComponentId active_face_id)
 
 ON_SubDComponentParameter (ON_SubDComponentPtr cptr)
 
 ~ON_SubDComponentParameter ()=default
 
unsigned ComponentDirection () const
 
unsigned ComponentId () const
 
const ON_SubDComponentId ComponentIdAndType () const
 
const ON_SubDComponentPtr ComponentPtr (const class ON_SubD &subd) const
 If the subd has a component with the same type and id, then that component is returned. More...
 
const ON_SubDComponentPtr ComponentPtr (const class ON_SubD *subd) const
 If the subd has a component with the same type and id, then that component is returned. More...
 
ON_SubDComponentPtr::Type ComponentType () const
 
const ON_SubDEdgeEdge (const ON_SubD *subd) const
 If this parameter references an edge and the subd has an edge with this->ComponentId(), then that edge is returned. More...
 
const ON_SubDComponentId EdgeFace () const
 In some cases, a face attached to this parameter's edge is required. In that case, this face is used. More...
 
unsigned EdgeId () const
 
double EdgeParameter () const
 Returns a parameter between 0 and 1 that identifies a point on the edge. This is always an intrisic parameter; ComponentDirection() is not taken into account. If the reference component is not an edge, then ON_DBL_QNAN is returned. More...
 
const ON_SubDEdgePtr EdgePtr (const ON_SubD *subd) const
 If this parameter references an edge and the subd has an edge with this->ComponentId(), then that edge is returned. More...
 
const ON_SubDFaceFace (const ON_SubD *subd) const
 If this parameter references a face and the subd has a face with this->ComponentId(), then that face is returned. More...
 
unsigned FaceId () const
 
const ON_SubDFaceParameter FaceParameter () const
 
const ON_SubDFacePtr FacePtr (const ON_SubD *subd) const
 If this parameter references a face and the subd has a face with this->ComponentId(), then that face is returned. More...
 
bool IsEdgeParameter () const
 
bool IsFaceParameter () const
 
bool IsSet () const
 
bool IsVertexParameter () const
 
ON_SubDComponentParameteroperator= (const ON_SubDComponentParameter &)=default
 
const ON_wString ToString (bool bUnsetIsEmptyString) const
 
const ON_SubDVertexVertex (const ON_SubD *subd) const
 If this parameter references a vertex and the subd has a vertex with this->ComponentId(), then that vertex is returned. More...
 
const ON_SubDComponentId VertexEdge () const
 In some cases, an edge attached to this parameter's vertex is required. In that case, this edge is used. More...
 
const ON_SubDComponentId VertexFace () const
 In some cases, a face attached to this parameter's vertex is required. In these cases this face is used. More...
 
unsigned VertexId () const
 
const ON_SubDVertexPtr VertexPtr (const ON_SubD *subd) const
 If this parameter references a vertex and the subd has a vertex with this->ComponentId(), then that vertex is returned. More...
 

Static Public Member Functions

static int Compare (const ON_SubDComponentParameter *lhs, const ON_SubDComponentParameter *rhs)
 Dictionary compares component type, component id, component direction, first parameter, second parameter and safely sorts nullptr to end. More...
 
static int CompareAll (const ON_SubDComponentParameter &lhs, const ON_SubDComponentParameter &rhs)
 Dictionary compares component type, component id, component direction, first parameter, second parameter. More...
 
static int CompareComponentTypeAndId (const ON_SubDComponentParameter &lhs, const ON_SubDComponentParameter &rhs)
 Dictionary compares component type and component id. More...
 
static int CompareComponentTypeAndIdAndDirection (const ON_SubDComponentParameter &lhs, const ON_SubDComponentParameter &rhs)
 Dictionary compares component type, component id, and component dir. More...
 

Static Public Attributes

static const ON_SubDComponentParameter Unset