Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDEdgePtr Class Reference

#include <opennurbs_subd.h>

Public Member Functions

bool ClearMark () const
 
ON__UINT8 ClearMarkBits () const
 
void ClearSavedSubdivisionPoints () const
 
void ClearSavedSubdivisionPoints (bool bClearNeighborhood) const
 
const ON_3dPoint DoubleSubdivisionPoint () const
 Get the location of the subdivision point of edge's subdivision vertex. More...
 
const ON_3dPoint DoubleSubdivisionPoint (unsigned relative_subdivided_end_index) const
 Get the location of the subdivision point of the specified subdivison edge. Note that when an edge is subdivided one time a new subdivision vertex and two subdivision edges are created. If one of the subdivion edges are subdivided again, then that creates a subdivision vertex. This version of ON_SubDEdge::DoubleSubdivisionPoint(...) returns the location of that vertex. The subdivided_end_index parameter specifies which of the two initial subdivision edges are used. More...
 
class ON_SubDEdgeEdge () const
 
ON__UINT_PTR EdgeDirection () const
 
const class ON_SubDFaceEdgeFace (int edge_face_index) const
 Get the edge's face ignoring orientation. More...
 
unsigned int EdgeFaceCount () const
 
unsigned int EdgeId () const
 
bool EdgeIsCrease () const
 
bool EdgeIsCreaseOrSharp () const
 
bool EdgeIsDartCrease () const
 
bool EdgeIsHardCrease () const
 
bool EdgeIsSharp () const
 
bool EdgeIsSmooth () const
 
bool EdgeIsSmoothNotSharp () const
 
ON_NurbsCurveEdgeSurfaceCurve (bool bClampEndKnots, ON_NurbsCurve *destination) const
 
ON_SubDEdgeTag EdgeTag () const
 
ON_SubDEdgeType EdgeType () const
 EdgeType() is typically used to generate text descriptions and in selection filtering. Do not confuse EdgeType() and EdgeTag(). More...
 
unsigned int GetEdgeSurfaceCurveControlPoints (ON_3dPoint *cvs, size_t cv_capacity) const
 
bool HasInteriorEdgeTopology (bool bRequireOppositeFaceDirections) const
 
bool IsActive () const
 
bool IsNotNull () const
 
bool IsNotNullAndVerticesAreNotNull () const
 
bool IsNull () const
 
bool Mark () const
 
ON__UINT8 MarkBits () const
 
const ON_SubDFaceNeighborFace (const ON_SubDFace *face, bool bStopAtCrease) const
 
const ON_3dVector RelativeControlNetDirection () const
 
const ON_Line RelativeControlNetLine () const
 
const ON_3dPoint RelativeControlNetPoint (int relative_vertex_index) const
 
const ON_3dVector RelativeDirection () const
 
const class ON_SubDFaceRelativeFace (int relative_face_index) const
 
bool RelativeFaceMark (int relative_face_index, bool missing_face_return_value) const
 
ON__UINT8 RelativeFaceMarkBits (int relative_face_index, ON__UINT8 missing_face_return_value) const
 
const ON_3dPoint RelativePointAt (double normalized_edge_parameter, ON_SubDComponentLocation subd_appearance) const
 
double RelativeSectorCoefficient (int relative_vertex_index) const
 
const ON_SubDEdgeSharpness RelativeSharpness (bool bUseCreaseSharpness) const
 Edge sharpness oriented with respect to this ON_SubDEdgePointer's direction. More...
 
const class ON_SubDVertexRelativeVertex (int relative_vertex_index) const
 
unsigned RelativeVertexId (int relative_vertex_index) const
 
bool RelativeVertexMark (int relative_vertex_index, bool missing_vertex_return_value) const
 
ON__UINT8 RelativeVertexMarkBits (int relative_vertex_index, ON__UINT8 missing_vertex_return_value) const
 
const ON_3dPoint RelativeVertexPoint (int relative_vertex_index, ON_SubDComponentLocation point_location) const
 
const ON_3dPoint RelativeVertexSurfacePoint (int relative_vertex_index) const
 
ON_SubDVertexTag RelativeVertexTag (int relative_vertex_index) const
 
const ON_SubDEdgePtr Reversed () const
 
bool SetMark () const
 
bool SetMark (bool bMark) const
 
ON__UINT8 SetMarkBits (ON__UINT8 mark_bits) const
 
void SetRelativeSectorCoefficientForExperts (int relative_vertex_index, double relative_sector_coefficient) const
 
void SetRelativeSharpness (ON_SubDEdgeSharpness relative_sharpness) const
 
const ON_ComponentStatus Status () const
 
const ON_3dPoint SubdivisionPoint () const
 Get the SubD edge Catmull-Clark subdivision point. More...
 

Static Public Member Functions

static const ON_SubDEdgePtr Create (const class ON_SubDComponentPtr &edge_component)
 
static const ON_SubDEdgePtr Create (const class ON_SubDEdge *edge)
 
static const ON_SubDEdgePtr Create (const class ON_SubDEdge *edge, ON__UINT_PTR direction)
 
static const ON_SubDEdgePtr Create (const class ON_SubDVertex *v0, const class ON_SubDVertex *v1)
 
static const ON_SubDEdgePtr CreateFromEndVertex (const class ON_SubDEdge *edge, const ON_SubDVertex *end_vertex)
 
static const ON_SubDEdgePtr CreateFromStartVertex (const class ON_SubDEdge *edge, const ON_SubDVertex *start_vertex)
 

Public Attributes

ON__UINT_PTR m_ptr
 

Static Public Attributes

static const ON_SubDEdgePtr Null