Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDVertexPtr Class Reference

#include <opennurbs_subd.h>

Public Member Functions

bool ClearMark () const
 
ON__UINT8 ClearMarkBits () const
 
void ClearSavedSubdivisionPoints () const
 
void ClearSavedSubdivisionPoints (bool bClearNeighborhood) const
 
bool IsActive () const
 
bool IsNotNull () const
 
bool IsNull () const
 
bool Mark () const
 
ON__UINT8 MarkBits () const
 
bool SetMark () const
 
bool SetMark (bool bMark) const
 
ON__UINT8 SetMarkBits (ON__UINT8 mark_bits) const
 
const ON_ComponentStatus Status () const
 
class ON_SubDVertexVertex () const
 
ON__UINT_PTR VertexDirection () const
 
unsigned int VertexId () const
 

Static Public Member Functions

static const ON_SubDVertexPtr Create (const class ON_SubDComponentPtr &vertex_component)
 
static const ON_SubDVertexPtr Create (const class ON_SubDVertex *vertex)
 
static const ON_SubDVertexPtr Create (const class ON_SubDVertex *vertex, ON__UINT_PTR vertex_direction)
 

Public Attributes

ON__UINT_PTR m_ptr
 

Static Public Attributes

static const ON_SubDVertexPtr Null