Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDFacePtr Class Reference

#include <opennurbs_subd.h>

Public Member Functions

bool ClearMark () const
 
ON__UINT8 ClearMarkBits () const
 
void ClearSavedSubdivisionPoints () const
 
void ClearSavedSubdivisionPoints (bool bClearNeighborhood) const
 
const ON_3dPoint DoubleSubdivisionPoint () const
 Get the location of the subdivision point of faces's subdivision vertex. More...
 
class ON_SubDFaceFace () const
 
ON__UINT_PTR FaceDirection () const
 
unsigned int FaceEdgeCount () const
 
unsigned int FaceId () const
 
bool IsActive () const
 
bool IsNotNull () const
 
bool IsNull () const
 
bool Mark () const
 
ON__UINT8 MarkBits () const
 
const ON_SubDFacePtr Reversed () const
 
bool SetMark () const
 
bool SetMark (bool bMark) const
 
ON__UINT8 SetMarkBits (ON__UINT8 mark_bits) const
 
const ON_ComponentStatus Status () const
 
const ON_3dPoint SubdivisionPoint () const
 

Static Public Member Functions

static int Compare (const ON_SubDFacePtr *lhs, const ON_SubDFacePtr *rhs)
 
static int CompareFacePointer (const ON_SubDFacePtr *lhs, const ON_SubDFacePtr *rhs)
 
static const ON_SubDFacePtr Create (const class ON_SubDComponentPtr &face_component)
 
static const ON_SubDFacePtr Create (const class ON_SubDFace *face, ON__UINT_PTR direction)
 

Public Attributes

ON__UINT_PTR m_ptr
 

Static Public Attributes

static const ON_SubDFacePtr Null