Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
ON_SubDComponentId Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDComponentId ()=default
 
 ON_SubDComponentId (const class ON_SubDEdge *e)
 
 ON_SubDComponentId (const class ON_SubDFace *f)
 
 ON_SubDComponentId (const class ON_SubDFace *f, unsigned face_corner_index)
 
 ON_SubDComponentId (const class ON_SubDVertex *v)
 
 ON_SubDComponentId (const ON_SubDComponentId &)=default
 
 ON_SubDComponentId (ON_SubDComponentPtr cptr)
 
 ON_SubDComponentId (ON_SubDComponentPtr::Type component_type, unsigned int component_id)
 
 ON_SubDComponentId (ON_SubDComponentPtr::Type component_type, unsigned int component_id, ON__UINT_PTR dir)
 
 ON_SubDComponentId (ON_SubDEdgePtr eptr)
 
 ON_SubDComponentId (ON_SubDFacePtr fptr)
 
 ON_SubDComponentId (ON_SubDFacePtr fptr, unsigned face_corner_index)
 
 ON_SubDComponentId (ON_SubDVertexPtr vptr)
 
 ON_SubDComponentId (unsigned face_id, ON__UINT_PTR face_dir, ON_SubDFaceCornerDex face_cdex)
 
 ~ON_SubDComponentId ()=default
 
unsigned int ComponentDirection () const
 
unsigned int ComponentId () const
 
const ON_SubDComponentPtr ComponentPtr (const class ON_SubD &subd) const
 Get the referenced SubD component from a component id. More...
 
const ON_SubDComponentPtr ComponentPtr (const class ON_SubD *subd) const
 Get the referenced SubD component from a component id. More...
 
ON_SubDComponentPtr::Type ComponentType () const
 
const ON_SubDEdgeEdge (const class ON_SubD &subd) const
 
const ON_SubDEdgeEdge (const class ON_SubD *subd) const
 
unsigned EdgeId () const
 
const ON_SubDEdgePtr EdgePtr (const class ON_SubD &subd) const
 
const ON_SubDEdgePtr EdgePtr (const class ON_SubD *subd) const
 
const ON_SubDFaceFace (const class ON_SubD &subd) const
 
const ON_SubDFaceFace (const class ON_SubD *subd) const
 
const ON_SubDFaceCornerDex FaceCornerDex () const
 
unsigned FaceId () const
 
const ON_SubDFacePtr FacePtr (const class ON_SubD &subd) const
 
const ON_SubDFacePtr FacePtr (const class ON_SubD *subd) const
 
bool IsEdgeId () const
 
bool IsFaceId () const
 
bool IsNotSet () const
 
bool IsSet () const
 
bool IsVertexId () const
 
ON_SubDComponentIdoperator= (const ON_SubDComponentId &)=default
 
const ON_SubDComponentId Reversed () const
 Create an ON_SubDComponentId that references the same SubD component but with the opposite value of this->ComponentDirection(). More...
 
const ON_wString ToString (bool bUnsetIsEmptyString, bool bDirectionPrefix) const
 Returns a string cN where N is ComponentId() and c is v, e or f for a vertex, edge or face component. Examples: If ComponentType is vertex and ComponentId() is 17, then the string will be "v17". If ComponentType is face, ComponentId() is 49, and FaceCornerDex is not set, the string will be "f49". If ComponentType is face, ComponentId() is 49, and FaceCornerDex() is ON_SubDFaceCornerDex(2,3), the string will be "f49.2". More...
 
const ON_SubDVertexVertex (const class ON_SubD &subd) const
 
const ON_SubDVertexVertex (const class ON_SubD *subd) const
 
unsigned VertexId () const
 
const ON_SubDVertexPtr VertexPtr (const class ON_SubD &subd) const
 
const ON_SubDVertexPtr VertexPtr (const class ON_SubD *subd) const
 

Static Public Member Functions

static int CompareTypeAndId (const ON_SubDComponentId &lhs, const ON_SubDComponentId &rhs)
 
static int CompareTypeAndIdAndDirection (const ON_SubDComponentId &lhs, const ON_SubDComponentId &rhs)
 
static int CompareTypeAndIdFromPointer (const ON_SubDComponentId *lhs, const ON_SubDComponentId *rhs)
 

Static Public Attributes

static const ON_SubDComponentId Unset
 type = unset and id = 0; More...