ModelUnitSystemValue Structure |
Namespace: Grasshopper.Rhinoceros
The ModelUnitSystemValue type exposes the following members.
Name | Description | |
---|---|---|
![]() | ModelUnitSystemValue(ActiveSpace, String) | Initializes a new instance of the ModelUnitSystemValue class |
![]() | ModelUnitSystemValue(UnitSystem, String) | Initializes a new instance of the ModelUnitSystemValue class |
![]() | ModelUnitSystemValue(UnitSystem, String, Double) | Initializes a new instance of the ModelUnitSystemValue class |
![]() | ModelUnitSystemValue(ModelUnitSystemValue, String, NullableDouble) | Initializes a new instance of the ModelUnitSystemValue class |
Name | Description | |
---|---|---|
![]() | ActiveSpace | |
![]() | BaseSystem | |
![]() | Factor | |
![]() ![]() | Feet | |
![]() ![]() | Inches | |
![]() ![]() | Meters | |
![]() | MetersPerUnit | |
![]() ![]() | Millimeters | |
![]() ![]() | ModelUnits | |
![]() | Name | |
![]() ![]() | None | |
![]() ![]() | PageUnits | |
![]() | Symbol | |
![]() ![]() | Unset |
Name | Description | |
---|---|---|
![]() | AdjustDocumentUnitSystem | |
![]() | CompareTo(Object) | |
![]() | CompareTo(ModelUnitSystemValue) | |
![]() | Equals(Object) | (Overrides ValueTypeEquals(Object).) |
![]() | Equals(ModelUnitSystemValue) | |
![]() | GetHashCode | (Overrides ValueTypeGetHashCode.) |
![]() | ToNonCustomUnitSystem | |
![]() | ToString | (Overrides ValueTypeToString.) |
![]() | ToUnitSystem |
Name | Description | |
---|---|---|
![]() ![]() | Equality | |
![]() ![]() | Inequality |
Name | Description | |
---|---|---|
![]() | _MetersPerUnit |