GH_ComponentAttributes Methods |
The GH_ComponentAttributes type exposes the following members.
Name | Description | |
---|---|---|
![]() | AppendToAttributeTree | (Overrides GH_AttributesTAppendToAttributeTree(ListIGH_Attributes).) |
![]() | ExpireLayout | (Overrides GH_AttributesTExpireLayout.) |
![]() | InvalidateCanvas |
The canvas must be invalidated when the mouse is near enough and
this component has variable parameters.
(Overrides GH_AttributesTInvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent).) |
![]() | IsMenuRegion |
Determines whether a point is available for context menu popups.
By default, IsMenuRegion calls IsPickRegion(PointF).
(Inherited from GH_AttributesT.) |
![]() | IsPickRegion(PointF) | (Overrides GH_AttributesTIsPickRegion(PointF).) |
![]() | IsPickRegion(RectangleF, GH_PickBox) |
Determines whether a rectangle is a valid pick region for this object.
By default, the picking rectangle is intersected with the Bounds rectangle.
(Inherited from GH_AttributesT.) |
![]() | IsTooltipRegion |
Determines whether a point is available for tooltip popups.
By default, IsMenuRegion calls IsTooltipRegion(PointF).
(Inherited from GH_AttributesT.) |
![]() | Layout | (Overrides GH_AttributesTLayout.) |
![]() ![]() | LayoutBounds | |
![]() ![]() | LayoutComponentBox |
Utility layout method for GH_Component style UI.
|
![]() ![]() | LayoutInputParams | |
![]() ![]() | LayoutOutputParams | |
![]() | NewInstanceGuid |
Generate a new instance GUID for the owner object.
(Inherited from GH_AttributesT.) |
![]() | NewInstanceGuid(Guid) |
Generate a new instance GUID for the owner object. Do not use this overload
unless you're > 1.95m and called David.
(Inherited from GH_AttributesT.) |
![]() | PerformLayout |
Recompute the layout for these attributes. This function is automatically called during
Drawing operations, so you typically don't have to.
(Inherited from GH_AttributesT.) |
![]() | PrepareForRender |
This method will always be called exactly once prior to Render().
This would be a good place to make sure all the necessary GUI data is up and running.
(Inherited from GH_AttributesT.) |
![]() | Read | (Inherited from GH_AttributesT.) |
![]() | Render | (Overrides GH_AttributesTRender(GH_Canvas, Graphics, GH_CanvasChannel).) |
![]() | RenderComponentCapsule(GH_Canvas, Graphics) |
Utility function, draws the complete component capsule including all parameter data.
|
![]() | RenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) |
Utility function, draws the component capsule including all specified elements.
|
![]() ![]() | RenderComponentParameters |
Utility method for rendering all component parameters.
|
![]() | RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, GH_ParamWireDisplay) |
Utility function for derived classes. This method draws all the wires going into the
left side of the attributes.
(Inherited from GH_AttributesT.) |
![]() | RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, IEnumerablePen) |
Utility function for derived classes. This method draws all the wires going into the
left side of the attributes.
(Inherited from GH_AttributesT.) |
![]() | RenderToCanvas |
Render these attributes into a Canvas control. This function places calls to
PrepareForRender() and Render(), you should override those.
(Inherited from GH_AttributesT.) |
![]() | RenderVariableParameterUI | |
![]() | RespondToKeyDown | (Inherited from GH_AttributesT.) |
![]() | RespondToKeyUp | (Inherited from GH_AttributesT.) |
![]() | RespondToMouseDoubleClick | (Inherited from GH_AttributesT.) |
![]() | RespondToMouseDown | (Overrides GH_AttributesTRespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).) |
![]() | RespondToMouseMove | (Inherited from GH_AttributesT.) |
![]() | RespondToMouseUp | (Inherited from GH_AttributesT.) |
![]() | SetupTooltip | (Overrides GH_AttributesTSetupTooltip(PointF, GH_TooltipDisplayEventArgs).) |
![]() | Write | (Inherited from GH_AttributesT.) |