Click or drag to resize

GH_Attributes<T>.RenderIncomingWires Method (GH_Painter, IEnumerable<IGH_Param>, GH_ParamWireDisplay)

Utility function for derived classes. This method draws all the wires going into the left side of the attributes.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected void RenderIncomingWires(
	GH_Painter painter,
	IEnumerable<IGH_Param> sources,
	GH_ParamWireDisplay style
)

Parameters

painter
Type: Grasshopper.GUI.Canvas.GH_Painter
The graphics object to paint with
sources
Type: System.Collections.Generic.IEnumerable<IGH_Param>
A list of sources that will be connected with the input grip of this attribute
style
Type: Grasshopper.Kernel.GH_ParamWireDisplay
Style for wire display.
See Also