GH_Painter Class |
Namespace: Grasshopper.GUI.Canvas
The GH_Painter type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Painter |
Constructor.
|
Name | Description | |
---|---|---|
![]() ![]() | ConnectionPath | |
![]() ![]() | ConnectionPathBezier | |
![]() | ConnectionVisible |
Test whether a wire ought to be drawn at all.
|
![]() ![]() | DetermineWireType |
Utility method for determining wire display types.
|
![]() | DrawBackground | |
![]() | DrawConnection | |
![]() | DrawMiddleGround | |
![]() | DrawNoDocumentMessage | |
![]() | DrawNULLBuffer | |
![]() | DrawPivots | |
![]() | DrawRecipientLinks(GH_Document) | |
![]() | DrawRecipientLinks(IGH_Param) | |
![]() | DrawStateFlags | |
![]() | GenerateWirePen_Fill |