GH_ComponentAttributesLayoutComponentBox Method |
Utility layout method for GH_Component style UI.
Namespace:
Grasshopper.Kernel.Attributes
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public static RectangleF LayoutComponentBox(
IGH_Component owner
)
Public Shared Function LayoutComponentBox (
owner As IGH_Component
) As RectangleF
Parameters
- owner
- Type: Grasshopper.KernelIGH_Component
Component to layout.
Return Value
Type:
RectangleFThe rectangle describing the box of the component name/icon.
See Also