Click or drag to resize

ToolbarFile Class

Represents a Rhino toolbar, or .RUI, file.
Inheritance Hierarchy
SystemObject
  Rhino.UIToolbarFile

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public sealed class ToolbarFile

The ToolbarFile type exposes the following members.

Properties
  NameDescription
Public propertyGroupCount
Get the number of toolbar groups in the toolbar file.
Public propertyId
Gets the id of the toolbar file.
Public propertyName
Gets the name, or alias, of the toolbar file.
Public propertyPath
Gets the full path to the toolbar file.
Public propertyToolbarCount
Get the number of toolbars in the toolbar file.
Top
Methods
  NameDescription
Public methodClose
Closes the toolbar file.
Public methodGetGroup(Int32)
Gets a toolbar group.
Public methodGetGroup(String)
Gets a toolbar group.
Public methodGetToolbar
Gets a toolbar.
Public methodSave
Saves the toolbar file.
Public methodSaveAs
Saves the toolbar file to a different path.
Top
See Also