Click or drag to resize

Localization Class

[Missing <summary> documentation for "T:Rhino.UI.Localization"]

Inheritance Hierarchy
SystemObject
  Rhino.UILocalization

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class Localization

The Localization type exposes the following members.

Properties
Methods
  NameDescription
Public methodStatic memberFormatArea
Format an Area string from a number
Public methodStatic memberFormatDistanceAndTolerance
Public methodStatic memberFormatNumber(Double)
Get a string version of a number.
Public methodStatic memberFormatNumber(Double, UnitSystem, DistanceDisplayMode, Int32, Boolean)
Get a string version of a number in a given unit system / display mode.
Public methodStatic memberFormatVolume
Format a Volume string from a number
Public methodStatic memberGetLanguages
Public methodStatic memberLocalizeCommandName(String)
Commands that need to be localized should call this function.
Public methodStatic memberLocalizeCommandName(String, Object)
Public methodStatic memberLocalizeCommandOptionName(String, Int32)
Public methodStatic memberLocalizeCommandOptionName(String, Int32, Int32) Obsolete.
DO NOT use this function, it is a trap to determine where context IDs have been copied from other, already extracted, strings.
Public methodStatic memberLocalizeCommandOptionName(String, Object, Int32)
Public methodStatic memberLocalizeCommandOptionValue(String, Int32)
Public methodStatic memberLocalizeCommandOptionValue(String, Object, Int32)
Public methodStatic memberLocalizeDialogItem
Look in the dialog item list for the specified key and return the translated localized string if the key is found otherwise return the English string.
Public methodStatic memberLocalizeForm
Look in the dialog item list for the specified key and return the translated localized string if the key is found otherwise return the English string.
Public methodStatic memberLocalizeString(String, Int32)
Returns localized version of a given English string. This function should be auto-generated by the RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.
Public methodStatic memberLocalizeString(String, Int32, Int32) Obsolete.
DO NOT use this function, it is a trap to determine where context IDs have been copied from other, already extracted, strings.
Public methodStatic memberLocalizeString(String, Object, Int32)
Returns localized version of a given English string. This function should be auto-generated by the RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.
Public methodStatic memberSetLanguageId
Sets the Id used for Localization in RhinoCommon. Only useful for when using RhinoCommon outside of the Rhino process
Public methodStatic memberUnitSystemName
Gets localized unit system name. Uses current application locale id.
Top
See Also