Localization Methods |
The Localization type exposes the following members.
Name | Description | |
---|---|---|
FormatArea |
Format an Area string from a number
| |
FormatDistanceAndTolerance | ||
FormatNumber(Double) |
Get a string version of a number.
| |
FormatNumber(Double, UnitSystem, DistanceDisplayMode, Int32, Boolean) |
Get a string version of a number in a given unit system / display mode.
| |
FormatVolume |
Format a Volume string from a number
| |
GetLanguages | ||
LocalizeCommandName(String) |
Commands that need to be localized should call this function.
| |
LocalizeCommandName(String, Object) | ||
LocalizeCommandOptionName(String, Int32) | ||
LocalizeCommandOptionName(String, Int32, Int32) | Obsolete.
DO NOT use this function, it is a trap to determine
where context IDs have been copied from other, already extracted,
strings.
| |
LocalizeCommandOptionName(String, Object, Int32) | ||
LocalizeCommandOptionValue(String, Int32) | ||
LocalizeCommandOptionValue(String, Object, Int32) | ||
LocalizeDialogItem |
Look in the dialog item list for the specified key and return the translated
localized string if the key is found otherwise return the English string.
| |
LocalizeForm |
Look in the dialog item list for the specified key and return the translated
localized string if the key is found otherwise return the English string.
| |
LocalizeString(String, Int32) |
Returns localized version of a given English string. This function should be auto-generated by the
RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.
| |
LocalizeString(String, Int32, Int32) | Obsolete.
DO NOT use this function, it is a trap to determine
where context IDs have been copied from other, already extracted,
strings.
| |
LocalizeString(String, Object, Int32) |
Returns localized version of a given English string. This function should be auto-generated by the
RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.
| |
SetLanguageId |
Sets the Id used for Localization in RhinoCommon. Only useful for when
using RhinoCommon outside of the Rhino process
| |
UnitSystemName |
Gets localized unit system name. Uses current application locale id.
|