Click or drag to resize

ExpandableContentUI Class

This class extends ContentUI to represent the default user interface which the RDK provides for a content.This is the UI created by the default implementation of CRhRdkCoreContent::CreateUI(). The main feature of this implementation is a 'holder' containing one or more expandable 'sections' (AKA 'roll-ups').
Inheritance Hierarchy

Namespace:  Rhino.UI.Controls
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ExpandableContentUI : ContentUI, 
	IDisposable

The ExpandableContentUI type exposes the following members.

Properties
  NameDescription
Top
Methods
  NameDescription
Public methodAddSection(ICollapsibleSection)
Add a section to the UI. Called \e before Create(). A generic controller is attached.
Public methodAddSection(ICollapsibleSection, IRdkViewModel)
Add a section to the UI with a custom controller. Called \e before Create().
Top
Fields
  NameDescription
Top
See Also