Click or drag to resize

ContentUI Class

This class represents the user interface (UI) of a content. A content's UI appears inside an editor which is represented by IRhRdkContentEditor.The UI is the part of the editor which allows the user to view and modify the persistent state of the selected content(s). This interface is implemented by RDK internally in the core content class, CRhRdkCoreContent. If you do not override CRhRdkCoreContent::CreateUI() you do not have to concern yourself with the details.If however, you do want to override CreateUI() to create your own custom UI, then you must derive your UI class from CRhRdkCustomContentUI and implement this interface to support your own UI design. \note CRhRdkCustomContentUI implements some of this interface for you.
Inheritance Hierarchy

Namespace:  Rhino.UI.Controls
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ContentUI : IDisposable

The ContentUI type exposes the following members.

Constructors
  NameDescription
Public methodContentUI
ContentUI constructor
Top
Properties
  NameDescription
Public propertyCppPointer
Top
Methods
  NameDescription
Public methodContentUIHolder
Returns the holder that contains the UI sections, if this is an expandable content UI with sections inside holders. Returns null for custom UIs.
Public methodDispose
Releases all resources used by the ContentUI
Public methodEditorUuid
Get the unique identifier of the editor that the UI is being displayed in.
Protected methodFinalize
ContentUI destructor
(Overrides ObjectFinalize.)
Public methodIsCreated
Returns true if the UI is created, else false
Public methodIsShown
Returns true if the UI is being shown, else false
Public methodUuid
Get the unique identifier of the UI.
Top
Fields
  NameDescription
Protected fieldm_cpp
Top
See Also