Click or drag to resize

StringHolder Class

This class is used to pass strings back and forth between managed and unmanaged code. This should not be needed by plug-ins.

If you are just dealing with an ON_wString*, use StringWrapper

Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersStringHolder

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class StringHolder : IDisposable

The StringHolder type exposes the following members.

Constructors
  NameDescription
Public methodStringHolder
Constructor
Top
Methods
  NameDescription
Public methodConstPointer
C++ pointer used to access the ON_wString, managed plug-ins should never need this.
Public methodDispose
IDispose implementation
Protected methodDispose(Boolean)
Called by Dispose and finalizer
Protected methodFinalize
Destructor
(Overrides ObjectFinalize.)
Public methodStatic memberGetString
Gets managed string from unmanaged ON_wString pointer.
Public methodNonConstPointer
C++ pointer used to access the ON_wString, managed plug-ins should never need this.
Public methodToString
Marshals unmanaged ON_wString to a managed .NET string
(Overrides ObjectToString.)
Public methodToStringSafe
Marshals unmanaged ON_wString to a managed .NET string and never returns null.
Top
See Also