Click or drag to resize

StringHolder Methods

The StringHolder type exposes the following members.

Methods
  NameDescription
Public methodConstPointer
C++ pointer used to access the ON_wString, managed plug-ins should never need this.
Public methodDispose
IDispose implementation
Protected methodDispose(Boolean)
Called by Dispose and finalizer
Protected methodFinalize
Destructor
(Overrides ObjectFinalize.)
Public methodStatic memberGetString
Gets managed string from unmanaged ON_wString pointer.
Public methodNonConstPointer
C++ pointer used to access the ON_wString, managed plug-ins should never need this.
Public methodToString
Marshals unmanaged ON_wString to a managed .NET string
(Overrides ObjectToString.)
Public methodToStringSafe
Marshals unmanaged ON_wString to a managed .NET string and never returns null.
Top
See Also