Click or drag to resize

ClassArrayString Class

Wrapper for a C++ ON_ClassArray<ON_wString> If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersClassArrayString

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ClassArrayString : IDisposable

The ClassArrayString type exposes the following members.

Constructors
  NameDescription
Public methodClassArrayString
Initializes a new ClassArrayString instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the number of strings in this array.
Top
Methods
  NameDescription
Public methodAdd
Adds a string to the list.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the ClassArrayString and optionally releases the managed resources
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToArray
Copies the unmanaged array to a managed counterpart.
Top
See Also