Click or drag to resize

PostEffectCollection Class

Represents the collection of post effects in render settings.
Inheritance Hierarchy

Namespace:  Rhino.Render.PostEffects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class PostEffectCollection : DocumentOrFreeFloatingBase, 
	IEnumerable<PostEffectData>, IEnumerable, IDisposable

The PostEffectCollection type exposes the following members.

Constructors
  NameDescription
Public methodPostEffectCollection
Create a utility object not associated with any document
Public methodPostEffectCollection(PostEffectCollection)
Create a utility object not associated with any document from another object
Top
Methods
  NameDescription
Public methodCopyFrom (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the PostEffectCollection
Protected methodFinalize (Overrides FreeFloatingBaseFinalize.)
Public methodGetEnumerator
Public methodGetSelectedPostEffect
Gets the selected post effect for a certain type into 'id'. Returns true if successful or false if the selection information could not be found.
Public methodMovePostEffectBefore
Move a post effect before another post effect in the list. Param 'id_move' is the id of the post effect to move. Param 'id_before' is the id of a post effect before which the post effect should be moved. If this is Guid.Empty, the post effect is moved to the end of the list. If the post effect identified by 'id_before' is not found, the method will fail. Returns true if successful, else false.
Public methodPostEffectDataFromId
Get a post effect data for an id.
Public methodSetSelectedPostEffect
Sets the selected post effect for a certain type.
Top
See Also