Click or drag to resize

PostEffect Class

[Missing <summary> documentation for "T:Rhino.Render.PostEffects.PostEffect"]

Inheritance Hierarchy
SystemObject
  Rhino.Render.PostEffectsPostEffect

Namespace:  Rhino.Render.PostEffects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class PostEffect : IDisposable

The PostEffect type exposes the following members.

Constructors
  NameDescription
Public methodPostEffect
Initializes a new instance of the PostEffect class
Top
Properties
  NameDescription
Public propertyCanDisplayHelp
Public propertyExecuteWhileRenderingOption
Public propertyId
Public propertyIsSelected
Return true if the post effect is selected.
Public propertyLocalName
Public propertyOn
Public propertyPostEffectType
Public propertyRequiredChannels
The RDK calls this method to determine which channels a post effect requires. If a required channel is not available, the RDK will hide the post effect's UI and display explanatory text instead. Note: As a convenience, the default implementation adds IRhRdkRenderWindow::chanRGBA to the output array. Most post effects should be able to use this default with no need to override the method.
Public propertySerialNumber
Public propertyShown
Public propertyStyles
Top
Methods
  NameDescription
Public methodAddUISections
Create each of your UI sections using 'new' and then call ui.AddSection() on them. RDK takes ownership of the sections.If your post effect does not need a UI, then your implementation of this method can be a no-op.
Public methodBeginChange
Public methodCanExecute
Return true if the post effect can execute, else false. The base implementation checks if the post effect is 'On' and 'Shown'. Post effect authors can override this to include other criteria but cannot disable the base criteria.
Public methodChanged
Public methodDisplayHelp
Displays the post effect's help page, if any.
Public methodDispose
Releases all resources used by the PostEffect
Public methodDispose(Boolean)
Releases the unmanaged resources used by the PostEffect and optionally releases the managed resources
Public methodEndChange
Public methodExecute
Execute the post effect.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetHashCode
A CRC of the state of this post effect.
(Overrides ObjectGetHashCode.)
Public methodGetParam
Get a parameter.
Public methodReadFromDocumentDefaults Obsolete.
Because post effects are now in the render settings, this function can no longer be called.
Public methodReadState
Read the state. If your post effect has no state, you must still return true for success.
Public methodStatic memberRegisterPostEffect(PlugIn)
Public methodStatic memberRegisterPostEffect(Assembly, Guid)
Public methodResetToFactoryDefaults
Reset the state to factory defaults.
Public methodSetParam
Set a parameter.
Public methodWriteState
Write the state. If your post effect has no state, you must still return true for success.
Public methodWriteToDocumentDefaults Obsolete.
Because post effects are now in the render settings, this function can no longer be called.
Top
See Also