Click or drag to resize

PostEffectCanExecute Method

Return true if the post effect can execute, else false. The base implementation checks if the post effect is 'On' and 'Shown'. Post effect authors can override this to include other criteria but cannot disable the base criteria.

Namespace:  Rhino.Render.PostEffects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public virtual bool CanExecute(
	PostEffectPipeline pipeline
)

Parameters

pipeline
Type: Rhino.Render.PostEffectsPostEffectPipeline
PostEffectPipeline

Return Value

Type: Boolean
Return true if the post effect can execute, else false
See Also