Click or drag to resize

PostEffect Methods

The PostEffect type exposes the following members.

Methods
  NameDescription
Public methodAddUISections
Create each of your UI sections using 'new' and then call ui.AddSection() on them. RDK takes ownership of the sections.If your post effect does not need a UI, then your implementation of this method can be a no-op.
Public methodBeginChange
Public methodCanExecute
Return true if the post effect can execute, else false. The base implementation checks if the post effect is 'On' and 'Shown'. Post effect authors can override this to include other criteria but cannot disable the base criteria.
Public methodChanged
Public methodDisplayHelp
Displays the post effect's help page, if any.
Public methodDispose
Public methodDispose(Boolean)
Public methodEndChange
Public methodExecute
Execute the post effect.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetHashCode
A CRC of the state of this post effect.
(Overrides ObjectGetHashCode.)
Public methodGetParam
Get a parameter.
Public methodReadFromDocumentDefaults Obsolete.
Because post effects are now in the render settings, this function can no longer be called.
Public methodReadState
Read the state. If your post effect has no state, you must still return true for success.
Public methodStatic memberRegisterPostEffect(PlugIn)
Public methodStatic memberRegisterPostEffect(Assembly, Guid)
Public methodResetToFactoryDefaults
Reset the state to factory defaults.
Public methodSetParam
Set a parameter.
Public methodWriteState
Write the state. If your post effect has no state, you must still return true for success.
Public methodWriteToDocumentDefaults Obsolete.
Because post effects are now in the render settings, this function can no longer be called.
Top
See Also