Click or drag to resize

SubDEdgeList Class

All edges in a SubD
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsSubDEdgeList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SubDEdgeList : IEnumerable<SubDEdge>, 
	IEnumerable

The SubDEdgeList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of SubD edges.
Top
Methods
  NameDescription
Public methodAdd
Add a new edge to the list.
Public methodFind(Int32)
Find an edge in this SubD with a given id
Public methodFind(UInt32)
Find an edge in this SubD with a given id
Public methodGetEnumerator
Implementation of IEnumerable
Public methodSetEdgeTags(IEnumerableSubDEdge, SubDEdgeTag)
Set edge tags for a list of edges. Useful for adding creases to SubDs
Public methodSetEdgeTags(IEnumerableInt32, SubDEdgeTag)
Set edge tags for a list of edges. Useful for adding creases to SubDs
Top
See Also