Click or drag to resize

NurbsCurvePointList Class

Provides access to the control points of a NURBS curve.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsNurbsCurvePointList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class NurbsCurvePointList : IEnumerable<ControlPoint>, 
	IEnumerable, IEpsilonComparable<NurbsCurvePointList>, IList<ControlPoint>, 
	ICollection<ControlPoint>

The NurbsCurvePointList type exposes the following members.

Properties
  NameDescription
Public propertyControlPolygonLength
Gets the length of the polyline connecting all control points.
Public propertyCount
Gets the number of control points in this curve.
Public propertyItem
Gets or sets the control point location at the given index.
Public propertyPointSize
Returns the control point size, or the number of doubles per control point. For rational curves, PointSize = Curve.Dimension + 1. For non-rational curves, PointSize = Curve.Dimension.
Top
Methods
  NameDescription
Public methodChangeEndWeights
Use a combination of scaling and reparameterization to change the end weights to the specified values.
Public methodContains
Determines if this list contains an item.
Public methodControlPolygon
Constructs a polyline through all the control points. Note that periodic curves generate a closed polyline with fewer points than control-points.
Public methodCopyTo
Copied the list to an array.
Public methodEnsurePrivateCopy
If you want to keep a copy of this class around by holding onto it in a variable after a command completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can call this function as many times as you want.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodGetPoint(Int32, Point3d)
Gets a world 3-D, or Euclidean, control point at the given index. The 4-D representation is (x, y, z, 1.0).
Public methodGetPoint(Int32, Point4d)
Gets a homogeneous control point at the given index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodGetWeight
Gets the weight of a control point at the given index. Note, if the curve is non-rational, the weight will be 1.0.
Public methodIndexOf
Gets the index of a control point, or -1.
Public methodMakeNonRational
Converts the curve to a Non-rational NURBS curve. Non-rational curves have unweighted control points.
Public methodMakeRational
Converts the curve to a Rational NURBS curve. Rational NURBS curves have weighted control points.
Public methodSetPoint(Int32, Point3d)
Sets a world 3-D, or Euclidean, control point at the given index. The 4-D representation is (x, y, z, 1.0).
Public methodSetPoint(Int32, Point4d)
Sets a homogeneous control point at the given index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodSetPoint(Int32, Point3d, Double)
Sets a world 3-D, or Euclidean, control point and weight at a given index. The 4-D representation is (x*w, y*w, z*w, w).
Public methodSetPoint(Int32, Double, Double, Double)
Sets a world 3-D, or Euclidean, control point at the given index. The 4-D representation is (x, y, z, 1.0).
Public methodSetPoint(Int32, Double, Double, Double, Double)
Sets a homogeneous control point at the given index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodSetWeight
Sets the weight of a control point at the given index Note, if the curve is non-rational, it will be converted to rational.
Public methodUVNDirectionsAt
Calculates the U, V, and N directions of a NURBS curve control point similar to the method used by Rhino's MoveUVN command.
Public methodValidateSpacing
Simple check of distance between adjacent control points
Top
See Also