Click or drag to resize

NurbsCurvePointListUVNDirectionsAt Method

Calculates the U, V, and N directions of a NURBS curve control point similar to the method used by Rhino's MoveUVN command.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public bool UVNDirectionsAt(
	int index,
	out Vector3d uDir,
	out Vector3d vDir,
	out Vector3d nDir
)

Parameters

index
Type: SystemInt32
Index of control point.
uDir
Type: Rhino.GeometryVector3d
The U direction.
vDir
Type: Rhino.GeometryVector3d
The V direction.
nDir
Type: Rhino.GeometryVector3d
The N direction.

Return Value

Type: Boolean
true if successful, false otherwise.
See Also