Click or drag to resize

BrepCurveList Class

Provides access to all the underlying curves in a Brep object.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsBrepCurveList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class BrepCurveList : IEnumerable<Curve>, 
	IEnumerable

The BrepCurveList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of curves in this list.
Public propertyItem
Gets the Curve at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Top
Methods
  NameDescription
Public methodAdd
Adds a curve
Public methodGetEnumerator
Get an enumerator that visits all curves.
Top
See Also