Click or drag to resize

UserDataList Class

Represents a collection of user data.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.CustomUserDataList

Namespace:  Rhino.DocObjects.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class UserDataList : IEnumerable<UserData>, 
	IEnumerable

The UserDataList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of UserData objects in this list.
Public propertyItem
Retrieve through indexer. Read-only access.
Top
Methods
  NameDescription
Public methodAdd
If the user-data is already in a different UserDataList, it will be removed from that list and added to this list.
Public methodContains
Checks for the existence of a specific type of user-data in this list Both .NET and native user-data is checked
Public methodFind
Finds a specific data type in this regulated collection.
Public methodGetEnumerator
Get enumerator for UserDataList
Public methodPurge
Removes all user data from this geometry.
Public methodRemove
Remove the user-data from this list
Top
See Also