Click or drag to resize

UnknownUserData Class

Represents user data with unknown origin.
Inheritance Hierarchy

Namespace:  Rhino.DocObjects.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class UnknownUserData : UserData

The UnknownUserData type exposes the following members.

Constructors
  NameDescription
Public methodUnknownUserData
Constructs a new unknown data entity.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Top
See Also