Click or drag to resize

DisplayPen Class

Pen used to define stroke applied to several DisplayPipeline draw functions
Inheritance Hierarchy
SystemObject
  Rhino.DisplayDisplayPen

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class DisplayPen

The DisplayPen type exposes the following members.

Constructors
  NameDescription
Public methodDisplayPen
Initializes a new instance of the DisplayPen class
Top
Properties
  NameDescription
Public propertyCapStyle
How caps are drawn at the ends of open curves
Public propertyColor
Color applied to stroke
Public propertyHaloColor
Halos are blended colors drawn around a curve for purposes like selection
Public propertyHaloThickness
Halos are blended colors drawn around a curve for purposes like selection
Public propertyJoinStyle
How corners of curves are joined
Public propertyPatternBySegment
Restart patterns at corners in a curve
Public propertyPatternLengthInWorldUnits
If true, lengths in pattern definition are interpreted to be in world units. If false, screen pixel distances are used.
Public propertyPatternOffset
Offset to apply to pattern. If RhinoMath.UnsetSingle, then pattern is centered to keep even dash lengths at ends
Public propertyThickness
Thickness for stroke
Public propertyThicknessSpace
Coordinate system for the pen's thickness
Top
Methods
  NameDescription
Public methodDuplicate
Create a duplicate of this display pen.
Public methodStatic memberFromLinetype
Create a display pen that matches a linetype definition
Public methodPatternAsArray
Get the pattern for this pen as an array of dash,gap,dash,gap... values
Public methodSetPattern
Set pattern to apply for a stroke.
Public methodSetTaper
Positions and thickness at those positions along a curve that define a taper.
Public methodTaperAsArray
Collection of positions and thicknesses at those positions to define a taper Rhino currently only supports either no taper or a single taper. An array is used here in case Rhino supports multiple taper values in the future.
Top
See Also