DisplayPen Properties |
The DisplayPen type exposes the following members.
Name | Description | |
---|---|---|
![]() | CapStyle |
How caps are drawn at the ends of open curves
|
![]() | Color |
Color applied to stroke
|
![]() | HaloColor |
Halos are blended colors drawn around a curve for purposes like selection
|
![]() | HaloThickness |
Halos are blended colors drawn around a curve for purposes like selection
|
![]() | JoinStyle |
How corners of curves are joined
|
![]() | PatternBySegment |
Restart patterns at corners in a curve
|
![]() | PatternLengthInWorldUnits |
If true, lengths in pattern definition are interpreted to be in world
units. If false, screen pixel distances are used.
|
![]() | PatternOffset |
Offset to apply to pattern. If RhinoMath.UnsetSingle, then pattern
is centered to keep even dash lengths at ends
|
![]() | Thickness |
Thickness for stroke
|
![]() | ThicknessSpace |
Coordinate system for the pen's thickness
|