Click or drag to resize

DisplayPen Methods

The DisplayPen type exposes the following members.

Methods
  NameDescription
Public methodDuplicate
Create a duplicate of this display pen.
Public methodStatic memberFromLinetype
Create a display pen that matches a linetype definition
Public methodPatternAsArray
Get the pattern for this pen as an array of dash,gap,dash,gap... values
Public methodSetPattern
Set pattern to apply for a stroke.
Public methodSetTaper
Positions and thickness at those positions along a curve that define a taper.
Public methodTaperAsArray
Collection of positions and thicknesses at those positions to define a taper Rhino currently only supports either no taper or a single taper. An array is used here in case Rhino supports multiple taper values in the future.
Top
See Also