Click or drag to resize

Transform Properties

The Transform type exposes the following members.

Properties
  NameDescription
Public propertyDeterminant
The determinant of this 4x4 matrix.
Public propertyStatic memberIdentity
Gets a new identity transform matrix. An identity matrix defines no transformation.
Public propertyIsAffine
Tests for an affine transformation. A transformation is affine if it is valid and its last row is [0, 0, 0, 1]. An affine transformation can be broken into a linear transformation and a translation.
Public propertyIsIdentity
Return true if this Transform is the identity transform
Public propertyIsLinear
Tests for a linear transformation. A transformation is affine if it is valid and its last row is [0, 0, 0, 1]. If in addition its last column is ( 0, 0, 0, 1)^T then it is linear. An affine transformation can be broken into a linear transformation and a translation.
Public propertyIsRotation
Returns true if this is a proper rotation.
Public propertyIsValid
Gets a value indicating whether or not this Transform is a valid matrix. A valid transform matrix is not allowed to have any invalid numbers.
Public propertyIsZero
True if matrix is Zero4x4, ZeroTransformation, or some other type of zero. The value xform[3][3] can be anything.
Public propertyIsZero4x4
True if all values are 0
Public propertyIsZeroTransformation
True if all values are 0, except for M33 which is 1.
Public propertyItem
Gets or sets the matrix value at the given row and column indices.
Public propertyM00
Gets or sets this[0,0].
Public propertyM01
Gets or sets this[0,1].
Public propertyM02
Gets or sets this[0,2].
Public propertyM03
Gets or sets this[0,3].
Public propertyM10
Gets or sets this[1,0].
Public propertyM11
Gets or sets this[1,1].
Public propertyM12
Gets or sets this[1,2].
Public propertyM13
Gets or sets this[1,3].
Public propertyM20
Gets or sets this[2,0].
Public propertyM21
Gets or sets this[2,1].
Public propertyM22
Gets or sets this[2,2].
Public propertyM23
Gets or sets this[2,3].
Public propertyM30
Gets or sets this[3,0].
Public propertyM31
Gets or sets this[3,1].
Public propertyM32
Gets or sets this[3,2].
Public propertyM33
Gets or sets this[3,3].
Public propertyRigidType
Gets a value indicating whether or not the Transform is rigid. A rigid transformation can be broken into a proper rotation and a translation, while an isometry transformation could also include a reflection.
Public propertySimilarityType
Gets a value indicating whether or not the Transform maintains similarity. The easiest way to think of Similarity is that any circle, when transformed, remains a circle. Whereas a non-similarity Transform deforms circles into ellipses.
Public propertyStatic memberUnset
Gets an XForm filled with RhinoMath.UnsetValue.
Public propertyStatic memberZeroTransformation
ZeroTransformation diagonal = (0,0,0,1)
Top
See Also