Click or drag to resize

RevSurface Properties

The RevSurface type exposes the following members.

Properties
  NameDescription
Public propertyAngle
Gets the start and end angles of revolution in radians. The interval angle must be increasing and satisfy RhinoMath.ZeroTolerance < Angle.Length<= 2.0 * System.Math.PI.
Public propertyAxis
Gets the axis of revolution.
Public propertyCurve
Gets the revolute curve.
Public propertyInterval
Interval specifies the parameterization for the angular parameter. Interval must be an increasing interval. The parameter Interval[0] corresponds to Angle[0] and the parameter Interval[1] corresponds to Angle[1].
Public propertyIsTransposed
If false, the "u" parameter is the angle parameter and the "v" parameter is the curve parameter. If true, the "u" parameter is the curve parameter and the "v" parameter is the angle parameter.
Top
See Also