Click or drag to resize

Line Properties

The Line type exposes the following members.

Properties
  NameDescription
Public propertyBoundingBox
Gets the line's 3d axis aligned bounding box.
Public propertyCode exampleDirection
Gets the direction of this line segment. The length of the direction vector equals the length of the line segment.
Public propertyFrom
Start point of line segment.
Public propertyFromX
Gets or sets the X coordinate of the line From point.
Public propertyFromY
Gets or sets the Y coordinate of the line From point.
Public propertyFromZ
Gets or sets the Z coordinate of the line From point.
Public propertyIsValid
Gets a value indicating whether or not this line is valid. Valid lines must have valid start and end points, and the points must not be equal.
Public propertyLength
Gets or sets the length of this line segment. Note that a negative length will invert the line segment without making the actual length negative. The line From point will remain fixed when a new Length is set.
Public propertyTo
End point of line segment.
Public propertyToX
Gets or sets the X coordinate of the line To point.
Public propertyToY
Gets or sets the Y coordinate of the line To point.
Public propertyToZ
Gets or sets the Z coordinate of the line To point.
Public propertyUnitTangent
Gets the tangent of the line segment. Note that tangent vectors are always unit vectors.
Public propertyStatic memberUnset
Gets a line segment which has Unset end points.
Top
See Also