Click or drag to resize

Interval Properties

The Interval type exposes the following members.

Properties
  NameDescription
Public propertyIsDecreasing
Returns true if T[0] > T[1].
Public propertyIsIncreasing
Returns true if T0 < T1.
Public propertyIsSingleton
Returns true if T0 == T1 != ON.UnsetValue.
Public propertyIsValid
Gets a value indicating whether or not this Interval is valid. Valid intervals must contain valid numbers.
Public propertyItem
Gets or sets the indexed bound of this Interval.
Public propertyLength
Gets the signed length of the numeric range. If the interval is decreasing, a negative length will be returned.
Public propertyMax
Gets the larger of T0 and T1.
Public propertyCode exampleMid
Gets the average of T0 and T1.
Public propertyMin
Gets the smaller of T0 and T1.
Public propertyT0
Gets or sets the lower bound of the Interval.
Public propertyT1
Gets or sets the upper bound of the Interval.
Public propertyStatic memberUnset
Gets an Interval whose limits are RhinoMath.UnsetValue.
Top
See Also