BrepEdge Properties |
The BrepEdge type exposes the following members.
Name | Description | |
---|---|---|
Brep |
Gets the Brep that owns this edge.
| |
Degree |
Gets the maximum algebraic degree of any span
or a good estimate if curve spans are not algebraic.
(Inherited from Curve.) | |
Dimension |
Gets the dimension of the object.
(Inherited from Curve.)The dimension is typically three. For parameter space trimming curves the dimension is two. In rare cases the dimension can be one or greater than three. | |
Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) | |
Domain |
Gets or sets the domain of the curve.
(Inherited from Curve.) | |
EdgeCurve |
Get the brep.Curves3D[] 3d curve geometry used by this edge or null.
| |
EdgeCurveIndex |
Get the brep.Curves3D[] index of the 3d curve geometry used by this edge or -1.
| |
EdgeIndex |
Gets the index of this edge in the Brep.Edges collection.
| |
EndVertex |
BrepVertex at end of edge
| |
HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
(Inherited from GeometryBase.) | |
HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) | |
IsClosed |
Gets a value indicating whether or not this curve is a closed curve.
(Inherited from Curve.) | |
IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
(Inherited from GeometryBase.) | |
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from GeometryBase.) | |
IsPeriodic |
Gets a value indicating whether or not this curve is considered to be Periodic.
(Inherited from Curve.) | |
IsSubDFriendly |
Returns true if the curve is a cubic, non-rational, uniform NURBS curve that is either periodic or has natural end conditions.
Otherwise, false is returned.
(Inherited from Curve.) | |
IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) | |
ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
(Inherited from GeometryBase.) | |
PointAtEnd |
Evaluates point at the end of the curve.
(Inherited from Curve.) | |
PointAtStart |
Evaluates point at the start of the curve.
(Inherited from Curve.) | |
ProxyBrepSubDEdgeId |
If this edge is part of a brep created by SubD.ProxyBrep(),
then the subd component id of the corresponding SubD edge is returned.
Otherwise 0 is returned.
| |
ProxyCurveIsReversed |
True if "this" is a curve is reversed from the "real" curve geometry
(Inherited from CurveProxy.) | |
SpanCount |
Gets the number of non-empty smooth (c-infinity) spans in the curve.
(Inherited from Curve.) | |
StartVertex |
BrepVertex at start of edge
| |
TangentAtEnd | Evaluate unit tangent vector at the end of the curve. (Inherited from Curve.) | |
TangentAtStart | Evaluates the unit tangent vector at the start of the curve. (Inherited from Curve.) | |
Tolerance |
Gets or sets the accuracy of the edge curve (>=0.0 or RhinoMath.UnsetValue)
A value of UnsetValue indicates that the tolerance should be computed.
The maximum distance from the edge's 3d curve to any surface of a face
that has this edge as a portion of its boundary must be <= this tolerance.
| |
TrimCount |
Gets the number of trim-curves that use this edge.
| |
UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) | |
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) | |
UserStringCount |
Gets the amount of user strings.
(Inherited from GeometryBase.) | |
Valence |
Gets the topological valency of this edge. The topological valency
is defined by how many adjacent faces share this edge.
|