Click or drag to resize

DisplayPipeline Properties

The DisplayPipeline type exposes the following members.

Properties
  NameDescription
Public propertyActiveObject
Public propertyActiveObjectNestingLevel
Public propertyActiveObjectNestingStack
Public propertyActiveTopLevelObject
Public propertyDefaultCurveThickness
Gets the curve thickness as defined by the current display mode. Note: this only applies to curve objects, Brep and Mesh wires may have different settings.
Public propertyDepthMode
Public propertyDisplayPipelineAttributes
Public propertyDpiScale
Scale factor used for high resolution displays. When a monitor that this pipeline is drawing to is at a DPI of 96, this value is one. On high DPI monitors, this value will commonly be greater than one.
Public propertyDrawingGrips
Gets a value that indicates whether the pipeline is currently in a grip drawing operation.
Public propertyDrawingSurfaces
Gets a value that indicates whether the pipeline is currently in a surface drawing operation. Surface drawing means draw the shaded triangles of a mesh representing the surface (mesh, extrusion, or brep). This is useful when inside of a draw event or display conduit to check and see if the geometry is about to be drawn as a shaded set of triangles representing the geometry. See DrawingWires to check and see if the wireframe representation of the geometry is going to be drawn.
Public propertyDrawingWires
Gets a value that indicates whether the pipeline is currently in a curve drawing operation. This is useful when inside of a draw event or display conduit to check and see if the geometry is about to be drawn is going to be drawing the wire representation of the geometry (mesh, extrusion, or brep). See DrawingSurfaces to check and see if the shaded mesh representation of the geometry is going to be drawn.
Public propertyFrameBuffer
Gets the contents of the frame buffer that this pipeline is drawing to.
Public propertyFrameSize
Gets the size of the frame buffer that this pipeline is drawing to.
Public propertyIsDynamicDisplay
Gets a value that indicates whether the viewport is in Dynamic Display state. Dynamic display is the state a viewport is in when it is rapidly redrawing because of an operation like panning or rotating. The pipeline will drop some level of detail while inside a dynamic display state to keep the frame rate as high as possible.
Public propertyIsInViewCapture
Gets a value that indicates whether this pipeline is currently drawing for ViewCaptureToFile or ViewCaptureToClipboard
Public propertyIsOpen
Is true of the pipeline is open, false otherwise.
Public propertyIsOpenGL
Gets a value indicating whether or not this pipeline is drawing into an OpenGL context.
Public propertyIsPrinting
Gets a value that indicates whether this pipeline is currently drawing for printing purposes.
Public propertyIsStereoMode
Gets a value that indicates whether this pipeline is currently using an engine that is performing stereo style drawing. Stereo drawing is for providing an "enhanced 3-D" effect through stereo viewing devices.
Public propertyModelTransform
Gets or sets the current model transformation that is applied to vertices when drawing.
Public propertyModelTransformIsIdentity
Gets a value that indicates whether the Model Transform is an Identity transformation.
Public propertyNestLevel
Gets the current nested viewport drawing level. This is used to know if you are currently inside the drawing of a nested viewport (detail object in Rhino).

Nest level = 0 Drawing is occurring in a standard Rhino viewport or on the page viewport.

Nest level = 1 Drawing is occurring inside a detail view object.

Public propertyRenderPass
Gets the current pass that the pipeline is in for drawing a frame. Typically drawing a frame requires a single pass through the DrawFrameBuffer function, but some special display effects can be achieved through drawing with multiple passes.
Public propertyShadingRequired
Gets or sets the "ShadingRequired" flag. This flag gets set inside the pipeline when a request is made to draw a shaded mesh but the current render engine doesn't support shaded mesh drawing...at this point the redraw mechanism will make sure everything will work the next time around.
Public propertyStereoProjection
Gets the current stereo projection if stereo mode is on.

0 = left

1 = right

If stereo mode is not enables, this property always returns 0.
Public propertySupportsShading
Gets whether or not this pipeline supports shaded meshes.
Public propertyViewport
Public propertyZBiasMode
Top
See Also