Click or drag to resize

SubDSurfaceInterpolator Methods

The SubDSurfaceInterpolator type exposes the following members.

Methods
  NameDescription
Public methodClear
Destroys the information needed to solve the interpolation.
Public methodStatic memberCreateFromMarkedVertices
Create an interpolator where all the marked vertices (unmarked if interpolatedVerticesMark is false) in the SubD are free vertices in the linear system used for interpolation, and the unmarked (marked if interpolatedVerticesMark is false) are fixed to their initial positions. Free vertices are can move as a result of the interpolation, and can receive an interpolation target location.
Public methodStatic memberCreateFromSelectedVertices
Create an interpolator where all the selected vertices in the SubD are free vertices in the linear system used for interpolation, and the unselected are fixed to their initial positions. Free vertices are can move as a result of the interpolation, and can receive an interpolation target location.
Public methodStatic memberCreateFromSubD
Create an interpolator where all the vertices in the SubD are free vertices in the linear system used for interpolation (i.e. can move as a result of the interpolation, and can receive an interpolation target location).
Public methodStatic memberCreateFromVertexIdList
Create an interpolator where all the listed vertices in the SubD are free vertices in the linear system used for interpolation, and the unselected are fixed to their initial positions. Free vertices are can move as a result of the interpolation, and can receive an interpolation target location.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodFixedVertexCount
Public methodInterpolatedVertexCount
Public methodInterpolatedVertexIndex
Public methodIsInterpolatedVertex(SubDVertex)
Public methodIsInterpolatedVertex(UInt32)
Public methodSolve
Solve the interpolation system, given target interpolation locations for the free vertices in the system. Updates the subd referenced by this system so the corresponding surface points are at the locations given by surfacePoints.
Public methodTransform
Apply an arbitrary transformation to the target interpolation points.
Public methodVertexIdList
Top
See Also